# $ K Main menu command summary

Commands


File menumenu_file

Edit menumenu_edit

View menumenu_view 

Window menumenu_window

Help menumenu_help
#K $ File menu commands
The File menu offers the following commands:

NewHID_FILE_NEW
Creates a new document (workspace, UFM, GTT, or GPD file).

OpenHID_FILE_OPEN
Opens an existing document (workspace, GTT, or GPD file).

CloseHID_FILE_CLOSE
Closes an opened document (workspace, UFM, GTT, or GPD file).

SaveHID_FILE_SAVE
Saves an opened document (workspace, UFM, GTT, or GPD file) using the same file name.

Save AsHID_FILE_SAVE_AS
Saves an opened document (workspace, UFM, GTT, or GPD file) to a specified file name.

ExitHID_APP_EXIT



Exits MiniDriver Development Tool.

# $ K + Edit menu commands

The Edit menu offers the following commands:

UndoHID_EDIT_UNDO
Reverse previous editing operation.

CutHID_EDIT_CUT
Deletes data from the document and moves it to the clipboard.

CopyHID_EDIT_COPY
Copies data from the document to the clipboard.

PasteHID_EDIT_PASTE
Pastes data from the clipboard into the document.

# $ K + View menu commands

The View menu offers the following commands:

ToolbarHID_VIEW_TOOLBAR
Shows or hides the toolbar.

Status BarHID_VIEW_STATUS_BAR
Shows or hides the status bar.



# $ K + Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple views of multiple documents in the application window:

New WindowHID_WINDOW_NEW
Creates a new window that views the same document.

CascadeHID_WINDOW_CASCADE
Arranges windows in an overlapped fashion.

TileHID_WINDOW_TILE
Arranges windows in non-overlapped tiles.

Arrange IconsHID_WINDOW_ARRANGE
Arranges icons of closed windows.

Split
Split the active window into panes.

Window 1, 2, ...HID_WINDOW_ALL
Goes to specified window.

# $ K + Help menu commands

The Help menu offers the following commands, which provide you assistance with this application: 

Help TopicsHID_HELP_INDEX
Offers you an index to topics on which you can get help.

AboutHID_APP_ABOUT
Displays the version number of this application.

#K $ New command (File menu)
Use this command to create a new document in MiniDriver Development Tool.  Select the type of new file you want to create in the File New dialog boxAFX_HIDD_NEWTYPEDLG. 
You can open an existing document with the Open commandHID_FILE_OPEN.

Shortcuts

Toolbar:
{bmc filenew.bmp}

Keys:
CTRL+N

#File New dialog box

Specify the type of document you wish to create:

MiniDriver Workspace

Glyph Translation Table (GTT)

Device Font Information (UFM)- this option is not available in the Beta 1 version.

Generic Printer Description (GPD)

#K $ Open command (File menu)
Use this command to open an existing document in a new window.  You can open multiple documents at once.  Use the Window menu to switch among the multiple open documents.  See Window 1, 2, ... commandHID_WINDOW_ALL.

You can create new documents with the New commandHID_FILE_NEW.

Shortcuts

Toolbar:
{bmc fileopen.bmp}

Keys:
CTRL+O

#File Open dialog box

The following options allow you to specify which file to open:

File Name

Type or select the filename you want to open.  This box lists files with the extension you select in the List Files of Type box. 

List Files of Type

Select the type of file you want to open: 

MiniDriver Workspace

Glyph Translation Table (GTT)

Device Font Information (UFM)- this option is not available in the Beta 1 version.

Generic Printer Description (GPD)

Drives

Select the drive in which MiniDriver Development Tool stores the file that you want to open. 

Directories

Select the directory in which MiniDriver Development Tool stores the file that you want to open.

Network...

Choose this button to connect to a network location, assigning it a new drive letter. 

#K $ Close command (File menu)
Use this command to close all windows containing the active document.  MiniDriver Development Tool suggests that you save changes to your document before you close it.  If you close a document without saving, you lose all changes made since the last time you saved it.  Before closing an untitled document, MiniDriver Development Tool displays the Save As dialog boxAFX_HIDD_FILESAVE and suggests that you name and save the document.

You can also close a document by using the Close icon on the document's window, as shown below:

{bml scmenu.bmp}

#K $ Save command (File menu)
Use this command to save the active document to its current name and directory.  When you save a document for the first time, MiniDriver Development Tool displays the Save As dialog boxAFX_HIDD_FILESAVE so you can name your document.  If you want to change the name and directory of an existing document before you save it, choose the Save As commandHID_FILE_SAVE_AS.

Shortcuts

Toolbar:
{bmc filesave.bmp}

Keys:
CTRL+S

#K $ Save As command (File menu)
Use this command to save and name the active document.  MiniDriver Development Tool displays the Save As dialog boxAFX_HIDD_FILESAVE so you can name your document.  

To save a document with its existing name and directory, use the Save commandHID_FILE_SAVE.

#Send command (File menu)
Use this command to send the active document through electronic mail.  This command presents a mail window with the active document attached to it.  You may then fill out the To: field, Subject: field, etc., and add text to the body of the message if you wish.  When you are finished you may click the "Send" button to send the message.

#File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:

File Name

Type a new filename to save a document with a different name.  A filename can contain up to eight characters and an extension of up to three characters.  MiniDriver Development Tool adds the extension you specify in the Save File As Type box.

Drives

Select the drive in which you want to store the document.

Directories

Select the directory in which you want to store the document.

Network...

Choose this button to connect to a network location, assigning it a new drive letter. 

# K $ 1, 2, 3, 4 command (File menu)
Use the numbers and filenames listed at the bottom of the File menu to open the last four documents you closed.  Choose the number that corresponds with the document you want to open.

#K $ Exit command (File menu)
Use this command to end your MiniDriver Development Tool session.  You can also use the Close command on the application Control menu.  MiniDriver Development Tool prompts you to save documents with unsaved changes.

Shortcuts

Mouse:
Double-click the application's Control menu button.


{bmc appexit.bmp}

Keys:
ALT+F4

#Undo/Can't Undo command (Edit menu)
Use this command to reverse the last editing action, if possible.   The name of the command changes, depending on what the last action was.  The Undo command changes to Can't Undo on the menu if you cannot reverse your last action.

Shortcuts

Toolbar:
{bmc editundo.bmp}

Keys:
CTRL+Z or


ALT-BACKSPACE


#Redo command (Edit menu)
<< Write application-specific help here. >>

#Cut command (Edit menu)
Use this command to remove the currently selected data from the document and put it on the clipboard.  This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
{bmc editcut.bmp}

Keys:
CTRL+X

#Copy command (Edit menu)
Use this command to copy selected data onto the clipboard.  This command is unavailable if there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
{bmc editcopy.bmp}

Keys:
CTRL+C

#Paste command (Edit menu)
Use this command to insert a copy of the clipboard contents at the insertion point.  This command is unavailable if the clipboard is empty.

Shortcuts

Toolbar:
{bmc editpast.bmp}

Keys:
CTRL+V

#K $ Toolbar command (View menu)
Use this command to display and hide the Toolbar, which includes buttons for some of the most common commands in MiniDriver Development Tool, such as File Open.  A check mark appears next to the menu item when the Toolbar is displayed.

See ToolbarAFX_HIDW_TOOLBAR for help on using the toolbar.

#K $ Toolbar
{bml hlptbar.bmp}

The toolbar is displayed across the top of the application window, below the menu bar.  The toolbar provides quick mouse access to many tools used in MiniDriver Development Tool,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click
To
{bmc filenew.bmp}
Open a new document.

{bmc fileopen.bmp}
Open an existing document.  MiniDriver Development Tool displays the Open dialog box, in which you can locate and open the desired file.

{bmc filesave.bmp}
Save the active document or template with its current name.  If you have not named the document, MiniDriver Development Tool displays the Save As dialog box.

{bmc fileprnt.bmp}
Print the active document.

{bmc editcut.bmp}
Remove selected data from the document and stores it on the clipboard.

{bmc editcopy.bmp}
Copy the selection to the clipboard.

{bmc editpast.bmp}
Insert the contents of the clipboard at the insertion point.

{bmc editundo.bmp}
Reverse the last editing.  Note:  You cannot undo some actions.

#K $Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be executed by the selected menu item or depressed toolbar button, and keyboard latch state. A check mark appears next to the menu item when the Status Bar is displayed.

See Status BarAFX_HIDW_STATUS_BAR for help on using the status bar.

#K $Status Bar
{bml hlpsbar.bmp}

The status bar is displayed at the bottom of the MiniDriver Development Tool window.  To display or hide the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate through menus.  This area similarly shows messages that describe the actions of toolbar buttons as you depress them, before releasing them.  If after viewing the description of the toolbar button command you wish not to execute the command, then release the mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator
Description
CAP
The Caps Lock key is latched down.

NUM
The Num Lock key is latched down.

SCRL
The Scroll Lock key is latched down.

#New command (Window menu)
Use this command to open a new window with the same contents as the active window.  You can open multiple document windows to display different parts or views of a document at the same time.  If you change the contents in one window, all other windows containing the same document reflect those changes.  When you open a new window, it becomes the active window and is displayed on top of all other open windows.

#Cascade command (Window menu)
Use this command to arrange multiple opened windows in an overlapped fashion. 

#Tile command (Window menu)
Use this command to arrange multiple opened windows in a non-overlapped fashion.

#Tile Horizontal command (Window menu)
Use this command to vertically arrange multiple opened windows in a non-overlapped fashion.

#Tile Vertical command (Window menu)
Use this command to arrange multiple opened windows side by side.

#Window Arrange Icons Command
Use this command to split the active window into panes.  You may then use the mouse or the keyboard arrows to move the splitter bars.  When you are finished, press the mouse button or enter to leave the splitter bars in their new location.  Pressing escape keeps the splitter bars in their original location.  << In a single document interface application, this command will appear on the View menu. >>

#1, 2, ... command (Window menu)
MiniDriver Development Tool displays a list of currently open document windows at the bottom of the Window menu.  A check mark appears in front of the document name of the active window.  Choose a document from this list to make its window active.  

#Index command (Help menu)

Use this command to display the opening screen of Help.  From the opening screen, you can jump to step-by-step instructions for using MiniDriver Development Tool and various types of reference information.  

Once you open Help, you can click the Contents button whenever you want to return to the opening screen.

#Using Help command (Help menu)

Use this command for instructions about using Help.

#About command (Help menu)

Use this command to display the copyright notice and version number of your copy of MiniDriver Development Tool.

#$Context Help command 

{bml curhelp.bmp}

Use the Context Help command to obtain help on some portion of MiniDriver Development Tool.  When you choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark.  Then click somewhere in the MiniDriver Development Tool window, such as another Toolbar button.  The Help topic will be shown for the item you clicked.

Shortcut

Keys:
SHIFT+F1

#Title Bar
<< Show your application's title bar here. >>

The title bar is located along the top of a window.  It contains the name of the application and document.

To move the window, drag the title bar.  Note: You can also move dialog boxes by dragging their title bars.

A title bar may contain the following elements:

{bmc bullet.bmp}
Application Control-menu button

{bmc bullet.bmp}
Document Control-menu button

{bmc bullet.bmp}
Maximize button

{bmc bullet.bmp}
Minimize button

{bmc bullet.bmp}
Name of the application

{bmc bullet.bmp}
Name of the document

{bmc bullet.bmp}
Restore button

# Scroll bars
Displayed at the right and bottom edges of the document window.  The scroll boxes inside the scroll bars indicate your vertical and horizontal location in the document.  You can use the mouse to scroll to other parts of the document.

<< Describe the actions of the various parts of the scrollbar, according to how they behave in your application. >>

#Size command (System menu)
Use this command to display a four-headed arrow so you can size the active window with the arrow keys.

{bml curarw4.bmp}

After the pointer changes to the four-headed arrow:

1.
Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the border you want to move.  

2.
Press a DIRECTION key to move the border.

3.
Press ENTER when the window is the size you want.

Note:  This command is unavailable if you maximize the window.

Shortcut
Mouse:
Drag the size bars at the corners or edges of the window.

#Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with the arrow keys.

{bmc curarw4.bmp}

Note:  This command is unavailable if you maximize the window.

Shortcut

Keys:
CTRL+F7

#$Minimize command (application Control menu)

Use this command to reduce the MiniDriver Development Tool window to an icon.

Shortcut
Mouse:
Click the minimize icon {bmc scmin.bmp} on the title bar.

Keys:
ALT+F9

#Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut
Mouse:
Click the maximize icon {bmc scmax.bmp} on the title bar; or double-click the title bar.

Keys:
CTRL+F10 enlarges a document window.

#Next Window command (document Control menu)

Use this command to switch to the next open document window.  MiniDriver Development Tool determines which window is next according to the order in which you opened the windows.

Shortcut

Keys:
CTRL+F6

#Previous Window command (document Control menu)

Use this command to switch to the previous open document window.  MiniDriver Development Tool determines which window is previous according to the order in which you opened the windows.

Shortcut

Keys:
SHIFT+CTRL+F6

#Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

{bml appexit.bmp}

Note:  If you have multiple windows open for a single document, the Close command on the document Control menu closes only one window at a time.  You can close all windows at once with the Close command on the File menu.

Shortcuts

Keys: 
CTRL+F4 closes a document window


ALT+F4 closes the <<YourType>> window or dialog box

#Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the Maximize or Minimize command.

#Switch to command (application Control menu)

Use this command to display a list of all open applications.  Use this "Task List" to switch to or close an application on the list.

Shortcut

Keys:
CTRL+ESC

Dialog Box Options

When you choose the Switch To command, you will be presented with a dialog box with the following options:

Task List

Select the application you want to switch to or close.

Switch To

Makes the selected application active.

End Task

Closes the selected application.

Cancel

Closes the Task List box.

Cascade

Arranges open applications so they overlap and you can see each title bar.  This option does not affect applications reduced to icons.

Tile

Arranges open applications into windows that do not overlap.  This option does not affect applications reduced to icons.

Arrange Icons

Arranges the icons of all minimized applications across the bottom of the screen.

<< Write application-specific help here. >>

#$Find command (Edit menu)

<< Write application-specific help here. >>

#$Find dialog box

<< Write application-specific help here. >>

#$Replace command (Edit menu)

<< Write application-specific help here. >>

#$Replace dialog box

<< Write application-specific help here. >>

#$Repeat command (Edit menu)

Use this command to repeat the last editing command carried out.  The Repeat menu item changes to Can't Repeat if you cannot repeat your last action.

Shortcut

Key:
F4

#$Clear command (Edit menu)

<< Write application-specific help here. >>

<< Write application-specific help here. >>

#$Next Pane

<< Write application-specific help here. >>

#$Prev Pane

<< Write application-specific help here. >>

#Modifying the Document

<< Write application-specific help here that provides an overview of how the user should modify a document using your application.  

If your application supports multiple document types and you want to have a distinct help topic for each, then use the help context i.d. generated by running the MAKEHELP.BAT file produced by AppWizard.  Alternatively, run MAKEHM as follows:


makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, then the help context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic for the first document type supported by your application.  AppWizard produces an alias in the .HPJ file for your application, mapping HIDR_DOC1TYPE to the HIDR_ produced by MAKEHM for that document type. >>

#No Help Available
No help is available for this area of the window.

# No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each AFX_HIDP_xxx value.  For example, AFX_HIDP_INVALID_FILENAME is the help topic for the Invalid Filename message box. >>
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