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Introduction


Welcome to the RL Tools 1.7, 32-bit Edition, tutorial.


For almost two years now, the RL Tools have been the localization strategy of choice at Microsoft for Windows based products.  Many localization teams have had great success with these tools and we've received much feedback.  This feedback has led us to create this tutorial.  We hope you find it helpful.


About the Resource Localization Tool Set


The Resource Localization Tool Set, version 1.7 (otherwise known as the RL Tools, 32-bit Edition) is a collection of tools that help prepare resource based Win32 products for distribution in the global marketplace.  The tools accomplish this by giving translators direct access to the product's Win32 resources without requiring the product to be recompiled.


This version of RL Tools are maintained by the Developer Relations Group’s Globalization team (who inherited the project from the old Systems International division).  They consist of three GUI tools (RLQuikEd, RLAdmin, and RLEdit) and a command line tool (RLMan).  There is another set for working with Windows 3.1 resources.  The two sets of tools are identical in all respects except for their host, target operating system, and the multi-language capabilities inherent in Win32 resources.


The Localization Process


Preparing a product for distribution in a foreign market is known as localization.  Localization means more than just translation.  It is often necessary to have more than one version of a product in any given language.  For instance, there may be both a British and an American English version of a product.  A homogeneous market is referred to as a locale and so preparing a product for distribution in different locales is referred to as localization.


Localizing software requires that each visual element of the product (and often some internal elements) be modified to best suit the targeted locale.  This may require translation to a foreign language and it usually at least requires that some things be reworded.


About This Tutorial


This tutorial is designed to provide a step-by step walk through of the overall operation of RLQuikEd, RLAdmin and RLEdit.  It is intended primarily for localizers and so the localization aspects of the tools are stressed.  More emphasis is placed on the operation of RLQuikEd and RLEdit than on RLAdmin because RLAdmin is typically not used by a localizer (it is generally used by an engineer assigned to act as an administrator for the project).


After carefully following the steps outlined in this tutorial, you should have a general idea of how the tools function and how the tools can be used to localize a product.


Getting Started


This section describes the steps necessary to prepare to run the tutorial.  We are assuming that the reader has a basic knowledge of DOS and Windows and has at least briefly examined the RL Tools User Guide which can be found in the WinWord file RLTOOLS.DOC on the RL Tools distribution point.


Getting Copies of the Tools


If you do not already have copies of the RL Tools, they can be found on their distribution point which is Level 2 of the Microsoft Developer Network.  The Windows 3.1 version and the 32-bit Edition can be found there.


To install the tools, run SETUP.EXE found in the DISK1 sub-directory.  This document will assume that you are familiar enough with DOS and Windows to perform these functions.


Make sure that you also get a copy of the sample glossary: PIGLATIN.TXT from the release point when you copy the other files.  This glossary will be used later by the tutorial.


Getting a Product to Work On


The tutorial will use the Windows NT file NOTEPAD.EXE to demonstrate the tools.


To prepare for the tutorial, you should use DOS or the File Manager to copy NOTEPAD.EXE from your Windows SYSTEM32 sub-directory to your RL Tools directory (the same directory where you keep your copy of the RL Tools).


You could use a different directory if you wish but we will use the RL Tools directory so we do not have to specify different directories from within the tools.  It keeps our directions simpler although it is really no harder to use a separate directory.


RLQuikEd


The purpose of this part of the tutorial is twofold:  first we want to demonstrate how RLQuikEd can be used to modify an executable's resources; and second we want to create a modified copy of NOTEPAD.EXE so that we can demonstrate the update capabilities of RLAdmin and RLEdit.


This part of the tutorial must be completed first before you can move on to the second part.


Loading Notepad into RLQuikEd


Start RLQuikEd.


Select the Open command from the File menu.  


You should see NOTEPAD.EXE listed as one of the files in the directory window.  Select it and click on the OK button to load Notepad into RLQuikEd.  You will be asked to supply the primary language and sub-language Ids for the resources which you wish to extract from NOTEPAD.EXE and for the language into which you will be localizing them.  You will also be asked to indicate whether you wish the localized resources to replace the extracted ones or appended to the file to make a multi-language NOTEPAD.EXE.  You might as well select Replace since the code in NOTEPAD does not allow the user to select a language.


RLQuikEd will then read all of the resources contained in the file NOTEPAD.EXE and display them in its workspace.


Examining The Resources in Notepad


When RLQuikEd loads resources from a file it displays them in its workspace.  The text in the workspace represents the localizable text contained in the file's resources.  Each line in the workspace represents a different line of localizable text.  For historical reasons, each line of localizable text is called a token.


At the bottom of the workspace is a status bar which displays information on the selected token.  There are four fields.  Select the first token by clicking on it once and you will be able to see the fields on the status bar.


The fields represent (in order) the resource ID (or "name"), the resource type, the internal ID (a value used by the RL Tools to uniquely identify the token), and the length of the token text (in characters).


With the first token selected (which should read "&File"), the status bar should contain the values: "1, MENU, 0, 5".  This tells us that this text came from a menu whose name is 1 and that the text is five characters long.


Pressing the Down Arrow will highlight the next token, pressing the Up Arrow will highlight the previous token.  Page Up and Page Down work in a similar manner but they jump an entire page at once as you might expect.  Home jumps to the beginning and End jumps to the end.  Browse around a bit and you should be able to easily find text that comes from dialog boxes, string tables, and other resources.


You can also locate tokens by using the Find commands in the Edit menu.


Making Changes


Once you are done browsing, we'll make some changes.


Go to the first token by pressing the Home key.  Then press return (or double click with the mouse) to bring up the edit dialog.


The same information contained in the status line is displayed in the edit box and there is text displayed in two text boxes marked Current Text and New Text.  The text in the Current Text window cannot be changed.  It displays what text was in the token when the edit window was opened.  It can be scrolled but it cannot be changed.  The text in the New Text window is where you type in what the localized text should be.  For now enter the characters "&Foo" and select OK.  (The & symbol, when used in most controls, tells Windows to put an underscore under the next character and use it as the "Hot-Key" for that function.)


When the edit window closes, you will see that the token is updated to reflect the changes you have made.


Resizing Dialogs


While browsing through the file you may have noticed that there are some DIALOG resources that contain nothing but numbers.  These numbers represent the coordinates of a control in the DIALOG.  The numbers are always immediately after the text of the control they came from.  Changing these numbers has the effect of resizing or moving dialog controls.  You could change these numbers directly from within RLQuikEd but there is a better way.


Both RLQuikEd and RLEdit have a command that allows you to use the Windows Dialog Editor to resize or localize dialog boxes.  To access this option, select Resize Dialogs from the Operations menu.  After a short while you should see the dialog editor come up.


When the dialog editor first comes up it will ask you for an include file.  At this point you should press the cancel button because you won't be using an include file.�


You will then be asked which dialog you want to work on.  We'll work on dialog number 14 which is the Page Setup dialog box.  Select dialog 14 and press the OK button.


It is beyond the scope of this tutorial to point out all the features of the Windows Dialog Editor so we won't try to do much now that we're here.  For now let's just change the size of the dialog by dragging the lower left hand corner of the dialog down and to the left.


Now close the dialog editor by selecting Exit from the File menu.  When the dialog editor asks if you want to save your changes select Yes.


After the dialog editor shuts down, RLQuikEd will ask you if you want to keep your changes.  Select Yes.


Saving Your Work


The last thing we want to do is to save our work in a new file.  Select the Save As command from the File menu and type in NEW.EXE for the name of the new file.


Now exit RLQuikEd by selecting Exit from the File menu and run NEW.EXE to see your changes.


You should see something that looks just like the Windows Notepad except it has the word Foo in the menu where the word File should be.  If you select the Page Setup command from the Foo menu (what used to be the File menu) you can see the changes you made to the Page Setup dialog box.


Notice that you were able to make all these changes without any programming and without using a compiler or similar development tool.  This is called "No-Compile" and it is the single most important feature of the Resource Localization Tool Set.  This feature of the RL Tools was the single most important factor that enabled Microsoft Systems to release Windows 3.1 simultaneously in seven languages.


RLAdmin & RLEdit


RLQuikEd is very good for making quick changes or for localizing a product that has already finished its development cycle but if a product is still undergoing changes then RLQuikEd just isn't practical because each time the product changes the localizer will have to re-localize the entire product.


RLAdmin and RLEdit were created to overcome this problem.


When a product is being developed it will typically be released to the localizers on a regular basis.  Each of these releases (called "drops") can then be used by RLAdmin and RLEdit to perform incremental updates of the localized projects.


During this part of the tutorial we will use RLAdmin and RLEdit to localize Notepad into Pig Latin.  We'll first localize the new version of Notepad (NEW.EXE) that was created in the first part of the tutorial.  Then we will simulate a new drop by copying the original version of Notepad (NOTEPAD.EXE) over the new version and we'll use the tools to update our localized version.  This part of the tutorial demonstrates how the domestic team, the project administrator, and the localizers work together using RLAdmin and RLEdit to create and maintain up-to-date localized versions of the product.


A brief overview of the localization cycle is as follows:


1.	The domestic team drops the first localizable version of the product.


2.	The administrator uses RLAdmin to set up a master project (MPJ) for each localizable file in the product.


3.	For each target locale, either the administrator or the localizer uses RLEdit to set up a project (PRJ) for each master project (MPJ) created by the administrator.


4.	Each localizer uses RLEdit to localize his projects and builds the target files which are then released for testing.


5.	The domestic team drops an updated version of the product.


6.	The administrator uses RLAdmin to update each master project.


7.	Each localizer uses RLEdit to update, localize, and release to testing each project.


8.	The cycle returns to step 5 until the product is released.


Creating the Master Project


The project administrator (typically an engineer) is normally the one who creates master projects but we need a master project file so that we can demonstrate how to use RLEdit and how update tracking works so we'll quickly demonstrate how it's done.


To create a master project file, run RLAdmin and select New from the Project menu.


Enter NOTEPAD for the name of the project and select OK.  RLAdmin will add the .MPJ extension for you.


RLAdmin will then ask for the names of the various files that make up a master project.


With the Source File text box selected, click on the Browse button.  RLAdmin will bring up a file list of all EXE files in the current directory.  Select NEW.EXE (or type NEW) and select OK.


RLAdmin will select NEW.EXE as the source file and it will suggest you use NEW.MTK for the master token file.  Resource Description Files are only used when the source file uses custom resources and since Notepad doesn't use custom resources we can leave this space blank.


Select OK and RLAdmin will extract all the tokens from NEW.EXE and create the master project.


Notice that all the tokens are marked in blue.  Tokens are colored according to their status.  Blue tokens are tokens that are brand new.  Red tokens are tokens that have changed since the last update.  Black tokens are tokens that have not changed since the last update.  The administrator may also chose to mark tokens as read/only (or non-localizable) in which case those tokens would be colored gray.


Everything was automatically saved for you when the master project was created so you don't need to save anything; just exit RLAdmin and you're ready to proceed.


Creating the Project


Once a master project has been created, a project must be created for each locale for which the product is going to be localized.  This can be done by either the project administrator or the localizer.  This decision depends on how management chooses to delegate the responsibility.  Typically it is simpler to have the project administrator do it.


We are only localizing to one locale (Pig Latin) so we'll only set up one project.


To create a project run RLEdit and select New from the Project menu.


When RLEdit asks for a project name enter PIGLATIN as the name of the project and press OK.  RLEdit will add the .PRJ extension for you.


RLEdit will then ask for the names of the various files that make up a master project.  You use the browse button to search for each of these files (as we did in RLAdmin) or you can type in the names of the files by hand.


Enter the following names for each of the files it asks for:


�SYMBOL 183 \f "Symbol" \s 10 \h�	Master Project File: 	NOTEPAD.MPJ


�SYMBOL 183 \f "Symbol" \s 10 \h�	Language Token File: 	PIGLATIN.TOK


�SYMBOL 183 \f "Symbol" \s 10 \h�	Target File: 	PIGLATIN.EXE�


�SYMBOL 183 \f "Symbol" \s 10 \h�	Glossary: 	PIGLATIN.TXT


The master project file is the name of the master project file we created earlier.  The language token file is where RLEdit will store all of the localized information.  The target file is the name of the localized file we wish to build.  The glossary contains suggested translations (in Pig Latin) for the various phrases found in Notepad.


Glossaries are typically provided by the linguistics department but they could also be created from earlier projects.  Glossaries are an optional feature which can greatly simplify the amount of work that is necessary to localize a product.


After entering all the file names listed above and pressing OK RLEdit will create the project and present all the tokens to the localizer so he can begin localization.


Localizing Text


RLEdit works almost exactly like RLQuikEd.  The cursor movement keys work the same way, tokens are edited in the same fashion and there is a status bar that is similar to the status bar in RLQuikEd.


RLEdit's status bar has five fields (instead of four).  These fields represent (in order) the resource ID (or "name"), the resource type, the internal ID, the status of the token, and the number of characters in the token text.


A token can be clean, dirty, or read-only.  Clean tokens are colored black and indicate tokens that have already been localized and have not changed since then.  Dirty tokens are colored red and indicate tokens that have either never been localized or whose original text has changed since they were last localized and therefore they must be localized again to bring them in harmony with the original text.  Read-only tokens are colored gray and represent tokens that should not be localized.


To localize text you could pick a token that you want to localize and either double click or press return (just like we demonstrated in RLQuikEd).  Typically a localizer only wants to localize dirty tokens.  To make this easier there is a Review command in the Edit menu.  


Select the Review command and you will be presented with an edit box for the first dirty token (in this case it's the very first token since they're all dirty).


The edit box displays the token's name, its type and its internal ID.  It also displays four text boxes. The upper box is where you enter the new translation.  The second box displays the current translation.  The third box displays the text in the unlocalized version of this token.  The fourth box displays how the unlocalized text used to read before the last update (if it's blank then this token either hasn't changed since the last update or it didn't exist before).


There are also two checkboxes which can be used to mark the token as dirty or read-only.  The read-only checkbox can also be used to override a read-only status on a token so that it can be changed.


As you can see, this token reads "&Foo" in the unlocalized version of this file.  (We changed it to this using RLQuikEd remember?)  Translate this token into Pig Latin by entering "Oo&fay" in the new translation box and press the OK button.


You will notice that RLEdit updates the token, marks it clean (notice it gets colored black) and then moves on to the next dirty token.


At the bottom of the edit dialog box there is a row of buttons.  OK is used to mark a token as clean and change its text.  Cancel is used to abort the edit box (and also the review command) while making no changes to the selected token.  Skip is used to move ahead to the next dirty token without changing the status of the current token.  Untranslate returns a token's text to whatever text that token currently has in the master project.  The other two buttons are used in conjunction with glossaries and are only active if a glossary was selected when the project was created.


The Translate button looks through the glossary and presents a suggested translation for the token each time it is pressed.  There may be more than one translation for a given phrase so if the suggested translation doesn't look quite right then you can press the Translate button again and you may be offered a different one.  You can tell when you've exhausted all the translations in the glossary because the original text will appear when there are no more translations.  Pressing Translate once again starts the cycle over again.


The Add to Glossary button adds a translation to the glossary.  It takes the text from the New Translation text box and enters it into the glossary as a suggested translation for the text in the Current Master Text box.


Press the Translate button to bring up a suggested translation for this token.  Now press the OK button to accept the translation.


Continue like this for at least a dozen tokens: pressing Translate to get a suggested translation and pressing OK to translate the token.


You can localize the entire file this way (since PIGLATIN.TXT contains translations for virtually every token in Notepad) or you can decide to only translate a dozen or so tokens.  If you wish to stop the review command before you've seen all the tokens just press the Cancel button.  


Whether you localize the whole file or just part of the file, make sure that at least the top dozen tokens are marked clean (colored black).  This will help later when we demonstrate how the update capability works.


You could also choose to resize the dialog boxes with the Resize Dialogs command in the Operations menu just like we did with RLQuikEd but since we demonstrated how that works earlier we won't do it now.


Building the Target


To build our target file (PIGLATIN.EXE) all you have to do is select the Generate Target File command from the Operations menu.  Go ahead and do that now.


Now exit RLEdit (your work is automatically saved for you) and use the File Manager or the Program Manager to run PIGLATIN.EXE and you will be able to see the changes you have made.


Simulating a New Drop


Now that we've localized our version of Notepad (NEW.EXE), suppose that we get a new drop from the development team.  Some things have changed since we localized NEW.EXE.  We're going to have to update our project.


To simulate a change in our source file we'll replace it with the real version of Notepad.


Use your favorite file copy utility to copy NOTEPAD.EXE over the top of NEW.EXE.  (This will have the effect of changing our Foo menu back to a File menu since that's all we changed.)


Updating the Master Project


Now that the domestic team has dropped a new file to us, the project administrator will have to update the master project.


To do this, run RLAdmin and select Open from the Project menu.  Select the name of our master project (NOTEPAD.MPJ) and press OK.


That's all there is too it.  Whenever RLAdmin loads a master project file it checks to see if the file needs updating.  If so, RLAdmin updates the master token file automatically.


You'll notice that the first token is red and all the other tokens are black.  This tells us that only the first token has changed.  You can bring up the edit box (or use the Review command) if you want to see exactly how it has changed.


When you're ready to update the Pig Latin project close RLAdmin.  All of your work has automatically been saved for you.


Updating the Project


After the administrator updates the master project, all the localizer has to do to update his project is open it in RLEdit.


Run RLEdit and select Open from the Project menu.  Then select the PIGLATIN.PRJ project file and press OK.


Whenever RLEdit opens a project file it checks to see if the project file needs updating.  If so, RLEdit updates the file automatically.


You'll notice that any tokens you didn't localize earlier will still be dirty (red).  


Any tokens that you did localize will still be clean (black) except for the first token ("Oo&fay") which will be marked dirty since the token has changed in the master project file since the last update.


Select the Review command from the Edit menu to review all the dirty tokens.  RLEdit will show you that the first token has been changed from "&Foo" to "&File" since the last update.  Press the Translate button to display a suggested translation for "&File" and then press OK to make the change.


Building the Target


Now that you've updated the project it's time to build the updated target file.


Just as before, this is accomplished by selecting the Generate Target File command from the Operations menu.


Now you have an updated version of PIGLATIN.EXE ready to drop to testing.


Exit RLEdit and it will automatically save your work for you.  Then you can test out your localized file.


Conclusion


You should now have a basic understanding of how the localization process works with these tools.  We've discussed all the most important features of RLEdit and RLQuikEd.  The user's guide provides even more detailed information about the tools, including a complete description of all the file formats.  The on-line help file also provides a complete description of the tools and the file formats.


By putting these tools to good use you will find that it is possible to ship virtually any Windows resource based product simultaneously in several languages.

















If you wish to repeat this tutorial, delete PIGLATIN.PRJ, PIGLATIN.TOK, NEW.MTK, and NOTEPAD.MPJ before you begin.  This will assure that you are building brand new projects and that you aren't just reusing parts of the old ones.





�It may seem annoying to always have to press cancel when the Open Include File dialog comes up but this is actually a good feature.  This dialog comes up because we did not modify the dialog editor at all when we created the RL Tools and that's the way the dialog editor works.  Because we didn't create our own dialog editor, you can be sure that you are seeing the dialogs exactly the way the developers have seen them and exactly the way the user will eventually see them.  By not modifying the dialog editor we have guaranteed that you will always have the greatest amount of compatibility and functionality possible.


�In practice, all the files relating to a project (the language token file, the target file, and the glossary) are typically placed in a special directory so that the target file, and the source file can all share the same name without conflict.  (For instance, a French version of the product would probably be under an FRN directory.)  For our demonstration we've chosen to keep them in the same directory and just choose a different name so that we don't have to mess with creating another directory.
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