1. IE4 Shell Development Tips & Tricks

Version 0.8

This is a set of instructions on how to ease the development process for Internet Explorer 4.0 Shell developers.  Its goals are to decrease build time, decrease the time it takes to debug a module, and use a high level debugger (MSDEV, aka MSVC, DevStudio) wherever possible.

2. Building modules

An easy way to speed the module building process is to ask your manager for a faster dev machine!  Here are some additional ideas for speeding up builds.

2.1 Build under NT

Although the NT build environment can run under both win95 and winnt, most developers report a performance improvement (about 50%) when upgrading their win95 dev machine to winnt.  According to PC Magazine, the FAT16 file system is about 12% faster than NTFS, although your disk space will suffer when running FAT16 on large (2GB) volumes.

2.2 Don’t binplace

The NT build environment will put retail components with DBG information into the OBJ\I386 directory, and debug components with DBG information into the OBJD\I386 directory.  Then it runs binplace which puts the module (minus DBG information) and the DBG information (minus the module) into the \NT\DROP directory.  Typically you will only work with the combined modules - the binplace process is a slow, unnecessary step.

If you SET NO_BINPLACE=1 in your %_ntbindir%\private\developr\%_ntuser%\ setenv.cmd script, you can skip the binplacing process.

2.3 Only build directories you care about

When a project has different binaries for win95 and winnt, it is only necessary to build in the directories you need.  For instance if you are building in the shell32 directory and only need a winnt DLL, you can type


iebuild ~w95c ~w95cpp ~win95

If you only need a win95 binary, you can type


iebuild ~ntc ~ntcpp ~unicode ~winnt

It is handy to create aliases and/or custom tool menu items in MSDEV for these commands.

Obviously, this trick won’t work in the single binary components like SHDOCVW.DLL.  Remember, it is a requirement that all modules build in all environments, so be sure to do a complete “iebuild all” before checking in any code.

2.4 Building from within MSDEV

Building from within the MSDEV environment is handy because if the compiler finds a syntax error MSDEV can jump to the offending line of code using the Go To Next Error (F4) command.  MSDEV’s build environment will try to generate MAK files that don’t work in the NT Build Environment.  The correct approach is to create a custom command in the Tools -> Customize -> Tools dialog.  Here is one of my sample entries:

· Menu Text: Build Shell32 (win95)

· Command: iebuild.cmd

· Arguments: ~ntc ~ntcpp ~unicode ~winnt

· Initial Directory: d:\nt\private\shell\shell32

I also check the Prompt For Arguments box and the Redirect Output To Window box.  A new command will appear on the tools menu and selecting it will to builds from within MSDEV.

MSDEV’s Go To Next Error command can get lost trying to find a source file, sometimes it is necessary to File -> Open one file in the directory you are compiling in in order for it to find the other source files.

3. Propagate modules

Once the modules have been built, they need to be moved onto a machine for testing / debugging.  The operating system puts up several barriers to replacing shell components, but they can all be overcome.  One drastic measure is to shut down windows, copy files, and restart windows.  This process is very time consuming though, and with the tricks outlined below it is possible to develop / test / debug (even on a single machine) without ever rebooting windows.

3.1 Modules in use

Windows won’t let you replace a module that is already in use, so you must close all applications that are using the module you wish to debug.  Unfortunately for shell components, this isn’t as easy as clicking on the close button of an application.

3.1.1 Shut down the shell

The one obvious user of shell components is the operating system shell itself.  There are a couple of ways to shutdown Explorer and leave windows running.  When closing Explorer, it is a good idea to leave a command window running so you can still type in commands.  On win95 and winnt, go to the Start -> Shutdown dialog, hold down the shift-ctrl-alt keys on the left side of the keyboard, and click on No.  On winnt, you can also type kill -f explorer in a command window to kill the explorer process.

3.1.2 KnownDLL Issues

Both winnt and win95 support the concept of Known DLLs.  These are DLLs that will likely be loaded throughout all windows sessions.  To prevent these DLLs from being unloaded at logout time and then slowly reloaded when a new user logs in, windows does one additional LoadLibrary of the Known DLLs at bootup time and never frees them.

The Known DLL list is in the registry.  Under win95 it is stored in

HKEY_LOCAL_MACHINE

SYSTEM\CurrentControlSet\Control\SessionManager\KnownDLLs

(no space)

Under winnt it is stored in

HKEY_LOCAL_MACHINE

SYSTEM\CurrentControlSet\Control\Session Manager\KnownDLLs

(note the space)

If you remove DLLs from this list, then their reference count should go to zero when apps stop using them.  Unfortunately SETUP will restore this list, and since you should be installing new builds daily it becomes a hassle to keep deleting them.

Thankfully, both winnt and win95 support an additional exclude-from-known-dlls list.  There is some confusion as to where this list is on each operating system.  To the best of my knowledge, on win95 this list is in

HKEY_LOCAL_MACHINE

SYSTEM\CurrentControlSet\Control\Session Manager\ExcludeKnownDLLs

with a format similar to the KnownDLLs key.  For instance, adding SHDOCVW=“SHDOCVW.DLL” ought to allow shdocvw.dll to get unloaded.

To the best of my knowledge, on winnt the list is stored in

HKEY_LOCAL_MACHINE

SYSTEM\CurrentControlSet\Control\Session Manager

under the REG_MULTI_SZ value ExcludeFromKnownDlls.  Each DLL filename should be listed on a line by itself.  You will need to use REGEDT32 (not REGEDIT) to enter REG_MULTI_SZ strings.

You will need to reboot for these changes to take effect.

3.1.3 AlwaysUnloadDll

As a further perf improvement, the Explorer will not unload DLLs right away when their reference count goes to zero, but instead it keeps them loaded for an additional 5 minutes on the off chance that another application will want to use them soon.  You can disable this feature by creating the key

HKEY_LOCAL_MACHINE

SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AlwaysUnloadDll

and setting its default value to “1”.

You will need to reboot for these changes to take effect.

3.1.4 Additional win95 processes

Even when the shell is shut down, additional processes may still be running and keeping shell DLLs loaded.  Some of the common offenders are SYSTRAY, LORAGENT, and VERFIND.  Hit Ctrl-Alt-Del after you have shut down Explorer and only have a command window open.  Double click (or End Task) these and other programs.  Generally the only programs worth running on win95 are Command (your command window) and AutoSym (dynamic symbol loader, see below).  SYSTRAY has some special code that makes it take a long time to die on win95.  To remove this annoying delay I recommend deleting systray.exe on all test machines.

3.1.5 Shell32.DLL on NT

Even with all of these tricks, nobody has been able to get shell32’s reference count to go to 0 on winnt.  The only known workaround is to create a new directory, and put both shell32.dll and explorer.exe in there (don’t put any other DLLs like shdocvw here, for some reason windows will always grab the other DLLs from the winnt\system32 directory).  Then when it comes time to relaunch the shell (see below) execute the explorer.exe in this new directory, it will pick up the new shell32.dll too.

3.2 DBG and SYM files

In addition to propagating DLLs and EXEs, you also need to propagate debugging information.  Since it is faster to use un-binplaced modules that still have the DBG information bound to them, there is no need to create or propagate DBG files.

The wdeb386 debugger (win95 only) uses SYM files, and these can be found in the same directory as the DLLs.

3.2.1 Autosym

The AutoSym program will cause wdeb386 to load SYM files on the fly, so it isn’t necessary to reboot to load new symbols.  If AutoSym previously loaded a symbol file with the same name, it will unload the old file before loading the new one.

Sadly, if some other component (system.ini, runwdef.wrf) loaded a symbol file with the same name, AutoSym will cause wdeb386 to load an additional symbol file with the same name, and wdeb386 will get confused.  The best approach here is to remove shell symbol files (like shell32.sym, shdocvw.sym, etc) from system.ini and/or runwdeb.wrf and instead create a startup batch file that autosyms these SYM files.

4. Debugging

Although this is by no means exhaustive, here is a list of useful techniques for debugging shell components.

4.1 Relaunch the shell

There are two ways to relaunch the shell after it has been closed.  The first method is to type “explorer” in the command window, this will relaunch the shell.

On win95, relaunching explorer may cause a GP fault in the hashing code of shell32.  This is normal, but annoying.  The only useful action here is to close the explorer, wait a few seconds, and relauch it again.  We’ve tried to debug this hash table bug, it appears that some component is stepping on kernel32’s free list but nobody can figure out who, why, or how to prevent it.  Since this problem only affects shell developers nobody has put any serious effort into solving it either.

When explorer is relaunched, you will typically lose your old tray applets.  This is normal, although annoying.

The second method for restarting the shell is to run explorer from within MSDEV.  Inside MSDEV, create a new bogus project workspace (I call mine “shell”) that is a normal application (EXE).  In the Build -> Settings dialog, select the win32 debug folder on the left, and the Debug tab on the right.  In the General category, the executable for the debug session should be the full path and extension of explorer.exe.  Then you should be able to hit F5 (or Build -> Debug -> Go).  MSDEV will bring up some stupid dialog about wanting to rebuild some components, just answer No and the shell should launch from within MSDEV.  Now you can do a File -> Open in MSDEV, open a source file, hit F9 to set a break point, and the next time explorer executes that line of code you will break into the debugger.

4.2 WDEB386 specific tricks

4.2.1 Use “y /n” option for pretty output

The default wdeb386 output for prompts and register dumps is ugly.  If you are starting wdeb386 from the command line (such as runwdeb.bat) be sure to pass in the “/n” command line switch.  If you are running wdeb386 as a VXD (this is how LOR does it) then be sure to add “DebugCMD=y /n” to the [386Enh] section of your system.ini file.

4.2.2 Debug version of core win95 modules

If you run wdeb386 with the retail windows 95 core components, you are missing out on some truly great warnings and asserts to help you develop your code.  To get the debug windows 95 core components, you need to do the following:

· shut down windows

· copy your c:\windows\system\advapi32.dll and advapi32.sym file in a safe location

· connect to \\STRATOS\WIN95 (\\STRATOS\OSR2 for OSR2 machines)

· cd to BUILD950.6 (US\BLD1111 for OSR2 machines)

· run the “change” batchfile, opting for debug components

· restore your old ADVAPI32.DLL and SYM file (IE4 installs special versions of these files)

· reboot

4.2.3 Removing rips

Once you are running debug win95, you may encounter many “err … Abort Break Ignore” type messages on your rterm session.  If you want to disable them you can do one of two things:

· (for current session only) in the debugger type “e debugoptions 0 c;g”

· (permanent) in the [windows] section of win.ini, add “DebugOptions=0x0c00” and reboot

Debug win95 has separate rip code for diagnosing heap problems.  To disable these additional rips, enter the following in the debugger:

· e _breaklevel ff;e _fvalidatestop 0

4.3 MSDEV

4.3.1 MSVC 4.2 crashing in SHN0.DLL when doing a stack trace

On both win95 and winnt, doing a stack trace (clicking on the “Context” combobox) in MSVC version 4.2 will generally cause a GP Fault in MSDEV\BIN\SHN0.DLL.  I have no idea why this happens, the workaround is to uninstall MSVC 4.2 and install version 4.1 (the one without the Visual J++ logo on startup).

4.3.2 Simultaneous wdeb386 & msdev

it is possible on win95 to run both wdeb386 and the msdev debugger.  If an application faults or does an int3 (they are both intel 386 exceptions), wdeb386 will catch it first.  Just type GT and the standard windows fault dialog will pop up (for an int3 the dialog says an “Exception 03H” occured).  Click on the debug button, and MSDEV’s just in time debugger will take over and let you debug the problem.

4.3.3 Shared arena issues on win95

Certain DLLs like shlwapi and comctl32 are loaded in the shared arena on win95.  Unlike wdeb386, MSDEV has difficulty debugging dlls in the shared arena.  Break points can’t be set, and stepping over a procedure typically doesn’t work.  Possible workarounds are:

· Debug these DLLs on NT

· Use wdeb386

· Recompile these DLLS to load in the non-shared arena (for comctl32 you need to remove the asser in commctrl.c and remove the DLLBASE= line in the win95\sources file).  Although these DLLs need to be loaded in the shared arena for the retail product, loading them non-shared doesn’t seem to hurt anything during short debug sessions.

